Topic Title: My Crossfire Problem! Can't get CFX in higher than stock drivers!
Topic Summary: 13.11 CFx option, but 14.4 and 14.7 nothing.
Created On: 07/27/2014 03:44 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/27/2014 03:44 AM
User is offline View Users Profile Print this message

Author Icon
HazordousLove
Peon

Posts: 4
Joined: 07/27/2014

I have two video cards, Radeon R9 290 & R9 290X. I understand there is no need for these cards to have a bridge with the new tech from AMD for crossfire, and now have a huge problem. When I install catalyst v13.11 from the stock disk, I can see both cards enabled in the Advanced Veiw > Information > Hardware tab in catalyst. But, once I upgrade to any new driver past this, (14.4 or 14.7B) It wont show the Advanced Veiw > Gaming > CrossfireX option at all. Both my GPUs are "working", as I saw both in GPU-Z and in the Driver manager. I have tried DriverSweeper(DDU) and re-installing the drivers but not much seems to work. Any thoughts? P.S. More info about catalyst 14.7B. It shows both GPUs are there in Advanced Veiw > Information > Hardware, but the GPU that is NOT plugged into my monitor is Disabled.

Specs

 

  • ASRock Pro4 Z97 motherboard

  • 16GB 2133 G. Skill Ram

  • TWIN FROZR MSI Radeon R9 290/x

  • 850W EVGA PSU 80+G FM

  • i5-4670 3.4GHz

 07/27/2014 03:46 PM
User is offline View Users Profile Print this message

Author Icon
HoneyBadger84
Button Masher

Posts: 205
Joined: 06/10/2014

Try the 14.6 RC or Beta drivers and see if it's still an issue?  I haven't messed with the 14.7s at all, but if I can remember this thread tomorrow, I'll hook up the one 290 I have left with a 290X, and try these drivers, see if I have the same issue and report back (can't do it today cuz I have to sleep in like... 15 mins for work in 9hrs & some change).

 

But yeah, try the 14.6 Beta or RC drivers.  They should still be findable for download on Guru3d.com here: http://www.guru3d.com/files-details/amd-catalyst-14-6-rc2-(14-200-1004-june-20)-download.html ~ Those are the exact drivers I've run in the past with a 290+290X setup and they ran it fine with full Crossfire functionality, tested in Watch_Dogs... hope those help!



-------------------------

CPU: i7 3930k @ 4.6GHz 1.29V (Corsair H110-cooled) ~ Motherboard: Asus RoG Rampage IV Extreme 
RAM: G.Skill Sniper Gaming Series (4x4GB 2133MHz, CL9) ~ PSU: Corsair AX 1200W ~ Case: Enermax Fulmo GT
GPUs: 3x HIS R9 290X Reference (Core) Editions in TriFire, Max Load Temps: 71C/70C/71C during OC testing :-P

 07/28/2014 04:08 PM
User is offline View Users Profile Print this message

Author Icon
HazordousLove
Peon

Posts: 4
Joined: 07/27/2014

Well I installed the new drivers with no such luck. I did notice when I installed the driver catalyst had shown a yellow bubble instead of a green one like when I installed 14.6 RC2. I will tried both the RC and Beta version also, they did not work..... :\.



Edited: 07/28/2014 at 04:53 PM by HazordousLove
 07/28/2014 04:38 PM
User is offline View Users Profile Print this message

Author Icon
HazordousLove
Peon

Posts: 4
Joined: 07/27/2014

ALRIGHT HERE IS what it looks like completed. Also I will post the log for you.<?xml version="1.0"?><?xml-stylesheet type="text/xsl" href="Report.xml.xsl"?><monetreport xmlnst="urn:schemas-microsoft-comatatypes"><general><cmdline>-UI </cmdline><time>07/28/14 15:32:37</time><action>install</action><download></download></general><dcm><device> <name>AMD Radeon R9 200 Series</name><manufacture>Advanced Micro Devices, Inc.</manufacture><chiptype></chiptype><chipid>0xaac8</chipid><vendorid>0x1002</vendorid><ssid>0xaac8</ssid><ssvid>0x1462</ssvid><classcode>0x040300</classcode><revisionid>0x00</revisionid></device><primary><name>AMD Radeon R9 200 Series</name><manufacture>Advanced Micro Devices, Inc.</manufacture><chiptype></chiptype><chipid>0x67b1</chipid><vendorid>0x1002</vendorid><ssid>0x3081</ssid><ssvid>0x1462</ssvid><classcode>0x030000</classcode><revisionid>0x00</revisionid></primary><device><name>AMD Radeon R9 200 Series</name><manufacture>Advanced Micro Devices, Inc.</manufacture>chiptype></chiptype><chipid>0xaac8</chipid><vendorid>0x1002</vendorid><ssid>0xaac8</ssid><ssvid>0x1462</ssvid><classcode>0x040300</classcode><revisionid>0x00</revisionid></device><device><name>AMD Radeon R9 200 Series</name><manufacture>Advanced Micro Devices, Inc.</manufacture><chiptype></chiptype><chipid>0x67b0</chipid> <vendorid>0x1002</vendorid><ssid>0x3080</ssid><ssvid>0x1462</ssvid><classcode>0x030000</classcode><revisionid>0x00</revisionid>  </device></dcm> <exist> </exist>  <install><package><description>AMD Catalyst Install Manager</description><result>Succeed</result><version>8.0.916.0</version><size>20 </size></package><package><description>Microsoft Visual C++ 2012 Redistributable (x86</description><result>Succeed</result><version>11.0.50727</version><size>9 </size></package><package><description>AMD Display Driver</description><result>Succeed</result><version>14.200.0.0000</version><size>90 </size></package><package><description>HDMI Audio Driver</description><result>Succeed</result><version>9.0.0.9905</version><size>1 </size></package><package><description>Microsoft Visual C++ 2012 Redistributable (x64)</description><result>Succeed</result><version>11.0.50727</version><size>9 </size></package><package><description>AMD Accelerated Video Transcoding</description><result>Succeed</result><version>13.30.100.40522</version><size>3 </size></package><package><description>AMD Catalyst Control Center</description><result>Succeed</result><version>2014.0522.2157.37579</version><size>150 </size></package><package><description>ACP Application</description><result>Succeed</result><version>1.00.0000</version><size>1 </size></package><package><description>AMD Gaming Evolved App</description><result>Succeed</result><version>1.10.000</version><size>49 </size></package> </install>  <uninstall>  </uninstall>  <downloaded>  </downloaded>  <resource>    <hwinfo>Hardware information</hwinfo>    <existpkg>Existing packages</existpkg>    <pkg2inst>Packages for install</pkg2inst>    <pkg2uninst>Packages for uninstall</pkg2uninst>    <otherdev>Other detected devices</otherdev>    <errmsg>Error messages</errmsg>    <name>Name</name>    <manufacture>Manufacturer</manufacture>   <chiptype>Chip type</chiptype>    <chipid>Device ID</chipid>   <otherhw>Other hardware</otherhw>    <download>Download packages</download>   <succeed>Success</succeed>    <fail>Fail</fail>    <vendorid>Vendor ID</vendorid>    <classcode>Class Code</classcode>    <revisionid>Revision ID</revisionid>    <ssid>Subsystem ID</ssid>    <ssvid>Subsystem vendor ID</ssvid>    <header1>Catalyst™ Install Manager</header1>    <header2>Installation Report</header2>    <finalstatus>Final Status:</finalstatus>    <versionofitem>Version of Item:</versionofitem><size>Size:</size> <bytes>Mbytes</bytes> </resource></monetreport>

 

Installation Complete



Edited: 07/28/2014 at 04:46 PM by HazordousLove
Statistics
86373 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.