Topic Title: Crossfire Woes
Topic Summary:
Created On: 08/04/2014 05:26 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/04/2014 05:26 PM
User is offline View Users Profile Print this message

Author Icon
GoddamnWhatIsGoingOn?
Peon

Posts: 1
Joined: 08/04/2014

Hi folks, I am having a bunch of problems setting up crossfire on my system and was wondering as a general question (if you don't want to read the rest of this wall of text):

How much difficulty did you have setting up crossfire on your rig? Is there a set way of doing things? Or is it all a bit of guesswork like i suspect it might be?

Anyway my PC spec is

i5-4670 with H60 Corsair cooler

HD7770 Crossfire

MSI Z87-G43

8GB G Skill RAM

Corsair HX750 PSU

 

This PC was stable and running perfectly on a single 7770, I added the second as it was my friends old GPU and going spare so why not?

Did a wipe of display drivers and reinstall of AMD CCC, (using DDU) installed 1 card, then the other. Have had loads of probs which I will now list:

Worse performance in some games (Insurgency)

Audio disabled from motherboard (now have headphones plugged into monitor, no mic)

Disabled Crossfire in CCC, wrong card disabled, (GPU1 not 2)

Some games improved performance (Arma3) but visual artifacts on screen sometimes.

 

I've spent the brst part of 3 days trying to configure this properly and getting a bit peeved. I like tinkering with my PC but a lot of this makes no sense. I'm on the 3rd install of the AMD drivers and CCC, tempted to try a fresh Windows install (Win 7 64 bit) but I'm not sure it will change anything.

 

So my original question stands. What am I donig wrong? Crossfire obviously works for a lot of people, but not me. It's not exactly a high end setup (7770 lol) but what the hell is going on?

any insights gratefully recieved.

 

Jay

 

EDIT: Forgot to mention, Witcher 2 crashes constantly with Crossfire enabled, not sure if my system or the game is to blame, or how to find out...

 08/18/2014 09:31 PM
User is offline View Users Profile Print this message

Author Icon
Neon Lights
Peon

Posts: 3
Joined: 08/18/2014

Try this (to rule out which component is faulty, because I am rather sure that your problem is not a software problem):

-Try your second graphic card only

-Try another Crossfire bridge

-Try your first graphic card on the PCIe slot in which you would put the second graphic card

 

Statistics
85287 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.