Topic Title: New build... can't detect HDMI display
Topic Summary:
Created On: 02/26/2014 01:55 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/26/2014 01:55 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 02/24/2014

I just put this together.  It's uber low-budget.  Everything seems to run pretty well so far but I can't get Windows or Catalyst to detect my HDMI display.  I've tried installing/uninstalling/re-installing the latest official catalyst release as well as 14.2.  Still no detect.  Anybody got any ideas? 

AMD A10-7850k

Asus A88XM-A

2x4GB Crucial Ballistix

Kingston V300 120GB SSD

Windows 8.1 Pro x64

CoolMax V400 PSU

There doesn't seem to be any power issues.  All Windows Updates installed.  Catalyst 14.2 installed.  BIOS is 1102 (the latest).  I'm completely at a loss on why this won't detect HDMI.  I've got a cheap Dell i3 laptop with 8.1 on it that plugs and plays to HDMI no problem.  Anybody got any ideas?  This is my first build.  Already talked to Asus rep and Microsoft rep.  Waiting to hear back from AMD after putting in a support request.  Any suggestions for this noob would be greatly appreciated.

 02/26/2014 10:28 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 44
Joined: 03/19/2008

Try installing the video drivers that come on the disk for the mobo than go from there. Most likely will be Catalyst 13.10's.

 11/21/2014 07:10 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 7
Joined: 11/11/2014

having the same problems. Does anyone have a solution for this.

btw my config is amd a10-7850k, windows 8.1 64 bit, 8 GB RAM, msi a78m-e35.

Also I have fully updated OS, BIOS and Drivers

 11/29/2014 07:01 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 4
Joined: 11/27/2014

I have the same issue with Asus A88XM-A motherboard and A8 7600 The DVI signal is lost post windows boot and only vga is available and nothing on the HDMI. If I uninstall all the catalyst driver then the dvi signal is back but still no HDMI. I have used drivers from 13.15 till 14.9+ beta's and still no give.

     Install openelec on the machine and I can get the output from the HDMI so I guess its not the hardware. I am really shocked at the quality of the driver since there is not one proper driver that can get this to work.

93382 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.