Topic Title: Poor memory performance on Linux with APUs
Topic Summary: GPU power management hurts CPU performance on Linux with new APU
Created On: 03/19/2014 04:21 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/19/2014 04:21 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 03/19/2014

Graphics Card / CPU



AMD Catalyst Driver Version, and Driver History

Reproduced on 13.35 (14.3 beta 1.0 released 3/12/14), 13.30_rc3 (released 1/13/14), and 13.251


Operating System

Linux. OpenSuse 13.1

Linux simcoe 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux


Issue Details

The memory system performance with Kaveri under Linux is very poor. Running the stream benchmark (linked below) I only see about 5 GB/s bandwidth. This should be 10-12 on a normal DDR3 system.


With further investigation, it seems that the power management features of the graphics driver are affecting the CPU performance. When I run aticonfig --odgc I see that the GPU DRAM frequency is set to 333 MHz (out of max 667). 


However, if I run something compute intensive on the GPU (like ConstantBandwidth from the AMD APPSDK examples), the GPU memory frequency increases to 667. When I run the stream benchmark while the GPU is in high-performance mode I see the expected throughput (~10 GB/s).


Unfortunately, when I try to manually set the GPU memory frequency with aticonfig it tells me that my adapter is unsupported. "ERROR - ATI Overdrive(TM) is not supported on Adapter 0 - AMD Radeon(TM) R7 Graphics


Additionally, I did not see this problem with in Windows.


Motherboard or System Make & Model

Gigabyte GA-F2A88XM-D3H


Applications and Games

Confirmed with the stream benchmark ( and other workloads.


Motherboard BIOS Version



System Memory Type & Amount

Kingston. 1333 MHz 16 GB in 2 DIMMs


Additional Details

I ran the same benchmark in Windows and saw about double the performance from Linux.


Any suggestions as to how to mitigate this issue?

 03/31/2014 10:37 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 03/19/2014


I reflashed an older version of the gigbyte BIOS (F5) and this problem was solved. Just in case someone sees this problem in the future.

92891 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.