Topic Title: Radeon HD 6530D
Topic Summary: USB 3 problems
Created On: 04/25/2014 07:56 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/25/2014 07:56 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 04/25/2014

Windows 7 Pro 64
ASRock A75 Pro4-M mboard.
AMD A6-3500 K12 bridge. Chipset Revision 00
AHCI mode
USB Driver host controller - AMD 11/28/2012 amdxhc.sys and usbfilter.sys
USB Hub - AMD 11/28/2012 amdhub30.sys

Basically a new Thermaltake USB HD dock does not work in USB 3. I uninstalled fastusb and updated the chipset drivers and the dock began working. Fastusb came w/the ASRock MB install disc and sucks greatly according to many ASRock users.

I am having several problems with the dock, again, and I *assume* it is due to the USB 3 drivers because it works fine in USB 2.

I will say that once the U3/dock started working I was able to copy a massive amount of data on to the dock/drive w/no problem at all. 1 900mb folder copied just by worked great.

- If I plug the dock into any U3 port besides the only one I've ever used it in I get the 'format disk first' message. This was the msg rec'd prior to Fastusb removal and updating of chipset drivers. To be clear, If plug it into the original U3 port it will connect and if I plug it into any U2 port the dock/drive work fine.

-Copying files simply does not work. If I copy from the dock/drive to an internal HD, or vice versa, the same thing happens. It will copy at 120-140 Mb/s and then I will get 'the destination specified does not exist'. The folder for the dock/drive disappears and then the dock/drive will start cranking and Autoplay for the dock/drive will pop up. Note: I've only tried this w/relatively large files; 70Mb and bigger.

Problem seems to be related to USB 3.

I d/l'd the AMD Cataltyst utility and it installed all new drivers including USB. 

I have read some people saying that sometimes the USB drivers would not install correctly. 

How do I determine if I have the correct drivers?

Any help , appreciated!

 04/26/2014 08:28 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 04/25/2014

Can someone help please?

I uninstalled catalyst and everything related to it through programs features.

I then went into device manager and uninstalled all the USB items including the drivers.

I ran the newest cataylst software and everything was updated except 2 items.  Device manager said the 2 items were 'other devices'.  I chose to manually install the drivers and pointed to C:\AMD. 

Windows says "Win found software ware but encountered an error'.  The error being that it can find the file!?! 

It's trying to install the USB 3 drivers which is my PROBLEM.

ANY HELP would be greatly appreciated.  I have a feeling if I let Windows find the driver that the USB 3 will not still not work correctly. 


93148 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.