Topic Title: No HDMI with Catalyst?
Topic Summary:
Created On: 04/27/2014 04:36 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/27/2014 04:36 PM
User is offline View Users Profile Print this message

Author Icon
Bui
Peon

Posts: 8
Joined: 04/26/2014

Graphics Card
A10 7850K Kaveri Radeon APU

AMD Catalyst Driver Version, and Driver History
14.4. (Previously used 13.1 to 14.3.)

Operating System
Windows 7 Ultimate 64-bit. Up to date

Issue Details

New built PC in Februrary, had no HDMI video and audio signal. Despite installing catalyst, the device manager primariy notified display adapters as 'VGA adapter' and in playback devices as a "Not Plugged In" status and I could not set changes or set defaults (options are grayed out). Note: DVI works either way.

After updating to 14.2-14.3 Catalyst and setting UEFI (Bios) on onboard devices realtek to disabled, I finally got full HDMI video and audio but it disabled other sound options direct from PC, such as headphone or speakers.

After Installing 14.4 Catalyst Beta, nothing changed and HDMI was fine although I wanted audio from PC. The UFEI also got an update that I flashed afterward which caused it to reset all memory and onboard device changes to its defaults. As expected, upon a restart I would lose HDMI video signal and hdmi audio. I restarted to go back into bios and re-adjust to my previous settings under the new bios version. However, I still had lost HDMI video and audio. After several reinstalls of drivers I found that disabling catalyst entirely (removing all related files to the AMD's catalyst using a utility software) would give me HDMI video but no audio (not plugged in status) as VGA adapter. Using catalyst would cause the video signal to be lost, even if I used any older version.


Motherboard or System Make & Model
A88XM-Plus

Power Supply

Corsair CS650M


Display Device(s) and Connection(s) Used
Sony Bravia HDTV 32"
Benq RL2455HM 24"

Note: Only using one display at a time.

Applications and Games

None but I would like Chivalry to perform better

CPU Details

A10-7850k
Memory increased to 2133 and reduced timings, nothing extreme.

Motherboard BIOS Version
Version 1302

System Memory Type & Amount
G.Skill Ripjaws Z Series 8GB (2x4GB) 240-Pin DDR3 SDRAM DDR3 2400 (PC319200) Desktop Memory Model F3-2400C10D-8GZH

Additional Hardware
1XCorsair 140mm fan.


Additional Details

HDMI works until post boot after windows logo loads.


I've done everything from full system recoveries, fresh installs, singled out different drivers, tested different cables, monitors, checked software and hardware.

I find there are many other forums that post with similar set ups with similar issues, overall I think there is a conflict between kaveri, catalyst and the asus motherboard but I have no idea what to do. It's not like the computer isn't operational but I would really like to have HDMI.

It's also a shame that I can't really play 1080p with kaveri either without low frames lol (any video card upgrade and oc timing suggestions would be great)

Other threads with similar issues: http://forums.amd.com/game/messageview.cfm?catid=483&threadid=170996&highlight_key=y&keyword1=7850k%20hdmi

http://forums.amd.com/game/messageview.cfm?catid=483&threadid=172001&highlight_key=y&keyword1=A88xm

 05/07/2014 08:55 PM
User is offline View Users Profile Print this message

Author Icon
juicebox
Peon

Posts: 1
Joined: 05/07/2014

Hi, 

I'm having the same problem.  New 7850K in a new ASUS A88XM-Plus.

Also new Kingston DDR3 2400MHz RAM 2x4GB

Out of box i had no video output so had to use an old discreet card to updat BIOS

With BIOS updated and latest AMD APU drivers I can only use VGA.  No HDMI detected (including during POST and BIOS/UEFI).  

(no problems with HDMI cables or TV, worked flawless on old PC)

Will try your diabling the onboard audio and see if that makes the HDMI work.  Although, like you would prefer to have the onboard analogue audio rather than audio through HDMI

Seams to be a problem with Kaveri and HDMI... AMD silent on this issue?

 

 

 

 05/08/2014 04:49 AM
User is offline View Users Profile Print this message

Author Icon
Bui
Peon

Posts: 8
Joined: 04/26/2014

Yeah, I've tried everything; it's an issue that's been ongoing for months with each beta of catalyst or whatever updates.

 11/11/2014 11:08 PM
User is offline View Users Profile Print this message

Author Icon
navsterr
Peon

Posts: 7
Joined: 11/11/2014

I am having the same problem with my a-10 7850k. Will someone Please help me solve the issue

 11/12/2014 07:37 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4102
Joined: 01/27/2008

That's odd, I can't use DVI but I can use HDMI and VGA with my MSI 88x board. Surely it must have something to do with the Mobo BIOS.

FWIW, be sure to complain to ASUS.



-------------------------

#1: FX-6350, Antec Kuhler 920, MSI 970 Gaming, Asus 5870/V2, ASUS Xonar D2X, GSkill (F3-14900cl9d-8gbxl), Antec Truepower New 750, Arc Midi, Win8.1pro x64
#2: MSI A88X-G45, AMD A10-7850K, IGP, Antec900 case, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P. Now on Win8.1pro cat 10.2

 11/12/2014 08:52 AM
User is offline View Users Profile Print this message

Author Icon
navsterr
Peon

Posts: 7
Joined: 11/11/2014

i had my MSI a78-e35 mobo checked by MSI service center. no problem found by them

 11/12/2014 08:52 AM
User is offline View Users Profile Print this message

Author Icon
navsterr
Peon

Posts: 7
Joined: 11/11/2014

i had my MSI a78-e35 mobo checked by MSI service center. no problem found by them

 12/11/2014 05:37 PM
User is offline View Users Profile Print this message

Author Icon
vagrahb
Peon

Posts: 4
Joined: 11/27/2014

Did anyone have any luck with this issue ? I have an AMD A8 7600 on a Asus A88XM-A and I have exactly the same issue. I have tried all the drivers from the 13.1 till the beta 14.x and no luck.

 12/14/2014 01:28 PM
User is offline View Users Profile Print this message

Author Icon
Space Beer
Peon

Posts: 13
Joined: 06/24/2014

Hi,

I have 7850K and Asus A88XM-Plus, and have no issues with HDMI on Windows 8.1. It works fine with 14.9 and 14.12 drivers. I have Benq G2222HDL on DVI, and LG 32LB5610 on HDMI port. All combinations works very well (double display, extended, only one display at time)

I have problem with HDMI sound (noise and crackling) on openSUSE 13.1/13.2 but I'm not sure if it's related to linux, catalyst or cheap HDMI cable I bought



-------------------------

AMD A10-7850K --- ASUS A88XM-PLUS --- 2x4GB Kingston HyperX Fury @2133Mhz --- Toshiba 500GB --- Cooler Master N200 --- Super Flower SF-450P14HE --- openSUSE 13.1 & Win 8.1 Pro

Statistics
88932 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.