Topic Title: Dual Graphics problem A8-5500 - HD 6570
Topic Summary: I can't get dual graphics to work with this combo
Created On: 05/08/2014 03:10 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/08/2014 03:10 AM
User is offline View Users Profile Print this message

Author Icon
m4ttY
Peon

Posts: 1
Joined: 05/08/2014

I have an AMD A8-5500 Quad core

HD 6570 1GB PCIeX16 card

ECS A55F2-M3 motherboard

450W Antec VP series

Radeon 8GB DDR3 1600 memory

 

I had the 14.4 beta drivers installed when i upgraded my cpu to the A8 from an A4. At first it didn't work by just enabling dual graphics in the bios. So I uninstalled the radeon 14.4 drivers. Rebooted computer and it had the 14.3 Beta drivers up and i had dual graphics working! then I got greedy(stupid?) and i wanted the 14.4 drivers that were recently released. So I tried to install those and ever since then I haven't been able to get it to work again.

What seems to happen is I have dual graphics enabled in my bios, the 14.4 drivers say they install fine. Reboot system as per the Catalyst Managers request. When computer comes back up i get an error saying AMD does not have drivers for your hardware or the driver is not working properly. And that happens everytime.

 

Any suggestions would help. I even tried taking out the discrete card, installing just the APU drivers(worked fine). then shutting down system, putting in 6570 and enabling dual graphics and same issue. Drivers give error.

 05/09/2014 01:34 AM
User is offline View Users Profile Print this message

Author Icon
drcmax
Peon

Posts: 3
Joined: 05/05/2014

theres a problem with the driver... same as mine.. so what i did was, uninstalling the newer 14.4 version and installing the older on... and i disable the auto update on my window... and it works fine now with me.. im running on a6-6400k with radein HD 7750 dual graphics...

 05/20/2014 10:15 PM
User is offline View Users Profile Print this message

Author Icon
Darth Revan
Nerfed

Posts: 51
Joined: 09/26/2010

there is a thread about this:

http://forums.amd.com/game/messageview.cfm?catid=483&threadid=173477&enterthread=y

Statistics
86507 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.