Topic Title: Multi-Monitor Success -- FirePro 2450/60 On Dell Optiplex 755 with PCIe 1.0 Slot
Topic Summary: PCI bus compatibility and bandwidth question -- it all works
Created On: 01/19/2014 01:58 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/19/2014 01:58 PM
User is offline View Users Profile Print this message

Author Icon
jmor111
Peon

Posts: 4
Joined: 01/19/2014

*** NEW NOTE -- SEE DETAILS OF SUCCESS IN REPLY ***

Hi,

I'm using four monitors in a business situation -- fantastic productivity tool.  Right now though the system (Windows 7 64-bit on a Dell Optiplex 755) is not stable, and crashes once in a while.  This is traceable to the other vendor's multi-monitor video drivers (cards are actually PCI).  So, I've settled on the FirePro 2450.  And does both VGA and DVI (cables/converters included).

1. THE BIG QUESTION PART ONE -- PCI 1.0A compatibility, i.e. will the 2450 card work in a PCI 1.0.A slot?  You can find lots of people who say "PCI Express is backwards compatible and you shouldn't have any problems" -- and a few people who say "PCIe 2.0 cards don't work on PCIe 1.0A" slots.

2. THE BIG QUESTION PART TWO -- Then there's the bandwidth question.  This is not for gaming.  But for four 20" monitors (say max 1920 X 1080 resolution), will there be a bandwidth issue through the PCIe 1.0 slot, even if it is technically compatible?

CLARIFICATION:  There are two different versions of the 2450 card, the x1 version (100-505841) and the x16 version (100-505840).  Both are $ 249 Canadian dollars from NewEgg.  Apparently both are PCIe V 2.0.  The 2460 card does DisplayPort output, which is nice, but I don't need it now -- it is apparently PCI V 2.1.

I'm thinking if this works, it could be really nice -- it's surprisingly difficult to get four monitors on this machine.  But there are huge numbers of people who'd like a technically viable and affordable solution for this.  And who just have an older PCI slot.

So, I'm hoping someone can verify before I actually buy the card and adapters.

A big thanks!  I'll report back if I go ahead.



Edited: 03/14/2014 at 06:14 AM by jmor111
 03/13/2014 03:14 PM
User is offline View Users Profile Print this message

Author Icon
jmor111
Peon

Posts: 4
Joined: 01/19/2014

Folks,

In answer to my own earlier question, and to help anyone else out who may be searching for a solution here, please allow me to share my success upgrade a nice off-lease Dell Optiplex 755 MT for multi-monitor.

If you are looking to use a great system for business, but add more monitors (which is fantastic for productivity) then this solution might be nice for you.

And making a multi-monitor graphics solution that works is both easy and tricky at the same time! It's easy if all the hardware is known to work together! So, this note is on that topic.

* Using ATI FirePro 2450 in PCI Express 16e slot.

* Four monitors (via included VGA or DVI adapters) PLUS the motherboard video still works! (Five in total).

* Upgraded the BIOS to the most recent. (A22)

* Note that this card runs PCI 2.0, and it works in what apparently is a PCIe 1.0a slot on the 755 MOBO. A PCIe 2.1 card may not work.

* This is for business, and all five monitors work fine now, even with YouTube. This is not intended as a gaming environment.

* There are a few things to try in the BIOS in terms of settings -- for a while there was a memory error and the thing wouldn't boot -- it took a little time to figure out he exact configuration.

* WIndows 7 is the OS used -- and Windows Aero works.

* I'm not long having any crashes associated with the older Jaton NVidia PCI-based cards we were using previously.

* Physical slot dimension are fine.

* Power consumption seems fine.

* Cost from ITX Canada was about $ 250 plus shipping, tax etc.

* This is the Sapphire version of the AMD ATI card, which is fine.

* The AMD part number is 100-505531.

* The five monitors are not identical (three different geometries and two vendors)

* Device manager lists the latest AMD video drivers for this card as installed and working -- I'm not completely clear if the drivers were installed from the download, or later.

* The actual install was a little hairy, and required persistence. When I reboot I will see about noting the exact BIOS settings.

* The system has not crashed once now, in a week of constant uptime, including with browsers open for long periods of time with 20 tabs or more and 80% physical memory usage.

* System has 6 GB RAM, is running 64-bit and BIOS A22.

* FYI, I'm not (yet) using any of the ATI special multi-monitor graphics management software. I'd like try maybe when I have more time (like probably never, as it seems to be working fine now).

Good luck.



Edited: 03/16/2014 at 12:09 PM by jmor111
 03/16/2014 12:08 PM
User is offline View Users Profile Print this message

Author Icon
jmor111
Peon

Posts: 4
Joined: 01/19/2014

FYI the 2450 card is EOL Jan 15, 2014 -- seems to be replaced by newer cards -- also seems to be quite a few units still in the channel.  Problem with the newer cards is that they are PCIe 2.1 -- and it's not clear (needs to be tested, can someone do this?) that a PCIe 2.1 card can work in what is apparently the PCIe 1.0a slot found in the Optiplex 755.

 03/21/2014 03:17 PM
User is offline View Users Profile Print this message

Author Icon
gotes
Peon

Posts: 1
Joined: 03/21/2014

Thanks for the info. I have an Optiplex 780 SFF and needed a low profile card to drive four monitors (2x 1920x1200, 2x 1920x1080). I got a second hand 2450 off ebay, but I can only get three monitors to work at any one time. I've flashed the latest BIOS but still no joy. Could be a power supply issue I guess.

The card replaced an Nvidia NVS 440, which is a full height card - I had it precariously balanced on top of the case - which could drive all four monitors, though the performance wasn't that great.

 11/06/2014 09:39 PM
User is offline View Users Profile Print this message

Author Icon
jmor111
Peon

Posts: 4
Joined: 01/19/2014

Nine months later -- the whole setup is working like a charm!  And reply to Gotes -- I've had bad experiences with SFF boxes -- they get too hot, as well as having smaller power supplies.

BTW, I posted this same info on the Dell forum.  And a community rep (SpeedStep) added more info about the cards -- and we engaged in a little bit of a dialogue concerning the fact that the 2450 is now EOL (end-of-life) and what could replace it, in terms of compatibility.

http://en.community.dell.com/support-forums/desktop/f/3515/t/19565555

Statistics
87491 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.