Topic Title: fglrx_drv.so fails to load with X.Org 7.3 - undefined symbol: noXFree86DRIExtension
Topic Summary:
Created On: 03/04/2013 09:03 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/04/2013 09:03 PM
User is offline View Users Profile Print this message

Author Icon
Trevin
Peon

Posts: 1
Joined: 03/04/2013

Red Hat recently pushed a point release upgrade from 6.3 to 6.4, which apparently includes a new version of X.Org.  As usual, I recompiled the fglrx driver (version 8.883) after rebooting.  Although the build was successful, X fails to start and logs the following error:

[   316.038] (II) LoadModule: "fglrx"
[   316.038] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[   316.054] (EE) Failed to load /usr/lib64/xorg/modules/drivers/fglrx_drv.so: /usr/lib64/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension
[   316.054] (II) UnloadModule: "fglrx"
[   316.054] (II) Unloading fglrx
[   316.054] (EE) Failed to load module "fglrx" (loader failed, 7)
[   316.054] (EE) No drivers available.
[   316.054]
Fatal server error:
[   316.054] no screens found
[   316.054] (EE)

I downloaded and compiled the latest fglrx driver available for 64-bit Linux, 9.003.3 (http://www2.ati.com/drivers/firepro/FirePro_9.003.3-Linux-x32x64-151130.zip), but got the same result.

My hardware is a FirePro V5800.

 

Statistics
81042 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.