Topic Title: Linux x86_64 Diablo 3 freezes and Ubuntu support 12.04.2 & 12.10
Topic Summary: Catalyst for HD2000-4000 needs improovement.
Created On: 04/07/2013 01:31 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/07/2013 01:31 PM
User is offline View Users Profile Print this message

Author Icon
kitsab
Peon

Posts: 11
Joined: 11/18/2011

Hello,

 

I'm running Ubuntu on my notebook.

Intel Core2 Duo 2.8Ghz

AMD HD4650 mobility

The basic issue Diablo 3 freezes under wine 1-3 minutes after the login sequence. The freeze affects the complete XServer keyboard is no longer reactive and the mouse courser could be moved but is not responding to clicks. The only way to get the XServer back to respond is killing the Diablo3 process with a remote SSH session by command line.

This issue only happens when using the hardware renderer. With software rendering and system basic graphic driver Diablo runs stable.

While testing all effects like AA, shadow, physics, fps limitation are disabled all settings are at minimum and problem occurs in windowed and in fullscreen mode.

Wine is properly configured, I've got desktop PC with Radeon 6970 with a completely similar software configuration and Diablo is running fine on wine.

 

About the isssue:

With installed catalyst driver. This happens with Ubuntu 12.04.1 with the following driver versions. 12.1, 12.6 13.1.

With installed software Ubuntu 12.04.2 and 12.10 it is not possible to install to get the system running due to lack driver support for Xorg 1.12.4 and above and Kernel >3.4. On both installs it is not possible to get catalyst (fglrx) working with Mobility HD4650, neither with the original configuration nor with different workarounds which are downgrading the Xorg Version to 1.11.x and Kernel <3.5.

By the way I installed windows for testing purposes and it also worked on a windows system with hardware accelleration.

I'm trying to get this running for weeks now.

Another problem is, I'm not able to trace this bug, because it is not visible in systemlog, dmesg, xorg.log and wine debug functions.

It's very dissapointing that this configuartion is not working and sadly in a notebook the graphic adapter replacement is not possible.

Any ideas?

 

 04/07/2013 01:55 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7027
Joined: 11/13/2009

There is a LAPTOP forum for LAPTOP issues. Why don't you post there? http://forums.amd.com/game/categories.cfm?catid=448&flcache=7442810&entercat=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 04/07/2013 02:21 PM
User is offline View Users Profile Print this message

Author Icon
kitsab
Peon

Posts: 11
Joined: 11/18/2011

I'm posting here, because it is a driver relating issue in my opinion.

 04/07/2013 02:39 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7027
Joined: 11/13/2009

Laptop graphics drivers are totally different than desktop graphics. Different drivers and issues..totally. If you need AMD support, then contact AMD and fill out a issue report form. Have you done that? AMD in its wisdom eliminated the linux open source forum..so you are stuck with the gaming forum..but your issue relates to laptops, and a legacy graphics card to boot. That's why there is a 'Extended support forum" for old graphics cards as well.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 04/08/2013 01:15 PM
User is offline View Users Profile Print this message

Author Icon
kitsab
Peon

Posts: 11
Joined: 11/18/2011

Thanks for the tip,

 

I did a support request now, but I guess this will end up in Nirvana!

 

There wasn't a option to choose Linux as OS, only a few windows versions were listed. And my graphic adapater was also not listed I've got to choose "other".

 

I'm curious about a response of AMD support.

 

BR

 

Kitsab

 09/03/2013 01:12 PM
User is offline View Users Profile Print this message

Author Icon
kitsab
Peon

Posts: 11
Joined: 11/18/2011

Hi,

 

I'm still waiting for an answer of my support request, I think they will not answer. The problem is still there. With the open source drivers I'm able to play Diablo 3 without crash but with the half performace/fps as I got it from catalyst drivers.

 

br

Kitsab

Statistics
84109 users are registered to the AMD Support and Game forum.
There are currently 11 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.