Topic Title: Brightness control not working with fglrx driver but yes with radeon
Topic Summary:
Created On: 08/10/2013 03:14 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/10/2013 03:14 PM
User is offline View Users Profile Print this message

Author Icon
shaola
Peon

Posts: 3
Joined: 08/10/2013

The brightness control is broken for my toshiba laptop with hd7660M graphics card.

 

The last driver that worked propperly was the 13.1, after that it wasn't working well, i had to make a script with a  loop changing manually /sys/class/backlight/acpi_video0/brightness
value to make it work.    This for example was the sript for changing the brigthness


#!/bin/bash
x=1
value=`cat /sys/class/backlight/acpi_video0/brightness`
value=$(( $valor + 1 ))
if [ $valor -le 7 ]
 then

 while [ $x -le 100 ]
do
echo $value>/sys/class/backlight/acpi_video0/brightness
 x=$(( $x + 1 ))
 done
else
value=7
while [ $x -le 100 ]
do
echo $value>/sys/class/backlight/acpi_video0/brightness
 x=$(( $x + 1 ))
 done


fi


 

 

as you see this script changes a hundred times the value (well, not changes, asigned the same value).  why this?

 

I discover that with and infinte loop worked always, with 25 times loop worked about 50% of the time and with a 100 times loop worked almost always.

 

 

The thing is with the last beta driver even this is not working anymore. 

 

Any sugestions?

 08/16/2013 04:54 PM
User is offline View Users Profile Print this message

Author Icon
Kent@AMD
Grinding Levels

Posts: 127
Joined: 01/10/2013

As this sounds like a driver bug, reporting it to the Linux driver team at www.amd.com/linuxreport is the best way to get the issue investigated and ultimately resolved.



-------------------------
AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
 08/16/2013 04:57 PM
User is offline View Users Profile Print this message

Author Icon
shaola
Peon

Posts: 3
Joined: 08/10/2013

Originally posted by: Kent@AMD As this sounds like a driver bug, reporting it to the Linux driver team at www.amd.com/linuxreport is the best way to get the issue investigated and ultimately resolved.

 

 

already done before posting here.

 

Thanks anyway for your response.

 

I manage to make ir work again with the loop thing,, but now is not working after suspend/resume.

 08/29/2013 04:49 PM
User is offline View Users Profile Print this message

Author Icon
Kent@AMD
Grinding Levels

Posts: 127
Joined: 01/10/2013

At least when the reports come in, they do look at them for future patches too. When it's an issue in the drivers itself, all we can do is raise the issue to them for investigation. Hopefully they can catch it early enough to get it out in the next release.



-------------------------
AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
 08/29/2013 04:56 PM
User is offline View Users Profile Print this message

Author Icon
shaola
Peon

Posts: 3
Joined: 08/10/2013

My guess is for doing that they would need much more information than the provided in the report, so i really don't give it to much hope

 08/30/2013 04:28 PM
User is offline View Users Profile Print this message

Author Icon
Kent@AMD
Grinding Levels

Posts: 127
Joined: 01/10/2013

If you filled out the form sufficiently, and gave them the information on the last page of the report, that should be all that they need. They wouldn't need extensive reproduction steps, just your hardware and the issue. If you told them what you posted here, that should be fine.



-------------------------
AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
Statistics
84832 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.