Topic Title: Android Emulator not working well in Linux with Cordova/Phonegap apps
Topic Summary: When using 3D accelerated drivers with some applications the screen is black or messed up
Created On: 08/19/2013 11:09 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/19/2013 11:09 AM
User is offline View Users Profile Print this message

Author Icon
AlexDusty
Peon

Posts: 1
Joined: 08/19/2013

Hello,

I'm trying to debug a phonegap/cordova application with the android emulator but when using the 3D acceleration Apache Cordova (formerly phonegap) applications gives bad rendering: the simple helloworld application gives a black screen.

After having installed Cordova 3.0 you can create a new application from scratch with these commands:

$ cordova create HelloWorldCordova
$ cd HelloWorldCordova/
$ cordova platform add android

$ cordova build

$ adb install ./platforms/android/bin/HelloCordova-debug.apk

(I can provide a premade APK if useful)

Here is my setup:

- kubuntu 64bit 13.4 with KDE 4.11

- AMD Drivers 13.8 beta (tested also with other versions)

- Radeon HD 6850

- Motherboard Asus M5A97

- 32G ram

- two Samsung monitor connected to DVI ports

The issue is reproducible using Genymotion 1.1 emulator that uses OpenGL for better performances.

Since the emulator appears to work fine with other cards, it seems to be a problem of the AMD driver.

Thanks for any help!

Alex

Statistics
85363 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.