Topic Title: Catalist latest and beta : realloc(): invalid next size (and hang )
Topic Summary: Flightgear halts with a glib error in call from fglrx driver.
Created On: 11/15/2013 11:27 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/15/2013 11:27 AM
User is offline View Users Profile Print this message

Author Icon
columbo
Peon

Posts: 1
Joined: 11/15/2013

When running Flightgear the program randomly hangs with the message :

 

*** glibc detected *** fgfs: realloc(): invalid next size: 0x00000000121cc5f0 ***

 

A gdb backtrace shows :

#0 0x00007ffff2756f6b in __lll_lock_wait_private () from /lib64/libc.so.6
#1 0x00007ffff26d73d5 in _L_lock_12561 () from /lib64/libc.so.6
#2 0x00007ffff26d4a72 in malloc () from /lib64/libc.so.6
#3 0x00007ffff7de7bbc in _dl_map_object_deps () from /lib64/ld-linux-x86-64.so.2
#4 0x00007ffff7dedc84 in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
#5 0x00007ffff7de9446 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#6 0x00007ffff7ded6dc in _dl_open () from /lib64/ld-linux-x86-64.so.2
#7 0x00007ffff2785142 in do_dlopen () from /lib64/libc.so.6
#8 0x00007ffff7de9446 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#9 0x00007ffff2785202 in __libc_dlopen_mode () from /lib64/libc.so.6
#10 0x00007ffff275d555 in init () from /lib64/libc.so.6
#11 0x00007ffff7bcaf40 in pthread_once () from /lib64/libpthread.so.0
#12 0x00007ffff275d674 in backtrace () from /lib64/libc.so.6
#13 0x00007ffff26ca215 in __libc_message () from /lib64/libc.so.6
#14 0x00007ffff26d04d6 in malloc_printerr () from /lib64/libc.so.6
#15 0x00007ffff26d36f2 in _int_realloc () from /lib64/libc.so.6
#16 0x00007ffff26d531d in realloc () from /lib64/libc.so.6
#17 0x00007fffeb5215c5 in ?? () from /usr/lib64/dri/fglrx_dri.so
#18 0x00007fffeb52163d in ?? () from /usr/lib64/dri/fglrx_dri.so
#19 0x00007fffeb71bab4 in ?? () from /usr/lib64/dri/fglrx_dri.so
#20 0x0000000000e5e9f3 in osg:rawable:raw(osg::RenderInfo& const ()
#21 0x00007ffff66faa0f in osgUtil::RenderLeaf::render(osg::RenderInfo&, osgUtil::RenderLeaf*) ()
from /usr/lib64/libosgUtil.so.100
#22 0x00007ffff66eeeeb in osgUtil::RenderBin:rawImplementation(osg::RenderInfo&, osgUtil::RenderLeaf*& ()
from /usr/lib64/libosgUtil.so.100
---Type <return> to continue, or q <return> to quit---
#23 0x00007ffff66eebf9 in osgUtil::RenderBin:raw(osg::RenderInfo&, osgUtil::RenderLeaf*& ()
from /usr/lib64/libosgUtil.so.100
#24 0x00007ffff66ef104 in osgUtil::RenderBin:rawImplementation(osg::RenderInfo&, osgUtil::RenderLeaf*& ()
from /usr/lib64/libosgUtil.so.100
#25 0x00007ffff6700bbf in osgUtil::RenderStage:rawImplementation(osg::RenderInfo&, osgUtil::RenderLeaf*& ()
from /usr/lib64/libosgUtil.so.100
#26 0x00007ffff66eebf9 in osgUtil::RenderBin:raw(osg::RenderInfo&, osgUtil::RenderLeaf*& ()
from /usr/lib64/libosgUtil.so.100
#27 0x00007ffff66ff4d4 in osgUtil::RenderStage:rawInner(osg::RenderInfo&, osgUtil::RenderLeaf*&, bool& ()
from /usr/lib64/libosgUtil.so.100
#28 0x00007ffff6700415 in osgUtil::RenderStage:raw(osg::RenderInfo&, osgUtil::RenderLeaf*& ()
from /usr/lib64/libosgUtil.so.100
#29 0x00007ffff67103ab in osgUtil::SceneView:raw() () from /usr/lib64/libosgUtil.so.100
#30 0x00007ffff5fdbe5c in osgViewer::Renderer::cull_draw() () from /usr/lib64/libosgViewer.so.100
#31 0x00007ffff5fdc6af in osgViewer::Renderer:perator()(osg::GraphicsContext*) () from /usr/lib64/libosgViewer.so.100
#32 0x00007ffff57437af in osg::GraphicsContext::runOperations() () from /usr/lib64/libosg.so.100
#33 0x00007ffff6029ce9 in osgViewer::ViewerBase::renderingTraversals() () from /usr/lib64/libosgViewer.so.100
#34 0x00007ffff6028578 in osgViewer::ViewerBase::frame(double) () from /usr/lib64/libosgViewer.so.100
#35 0x0000000000bd8cf5 in fgOSMainLoop() ()
#36 0x00000000006f97fd in fgMainInit(int, char**) ()
#37 0x00000000006bb0f4 in main ()

Lines 19 to 14 tell that the error is in fglrx-dri, so it's a driver bug i guess.
I tried with 13.4 and the beta version of the ati driver with the same result.

 

Graphics board : MSI HD 6450

libc version : 4.7.1

 

If anyone needs more info, just ask.

Thanks.

 

 

 12/31/2013 10:30 AM
User is offline View Users Profile Print this message

Author Icon
olicaro
Peon

Posts: 1
Joined: 12/31/2013

Hi,

I have exactly the same issue with Ubuntu 12.04 and Catalyst 13.12.

My system is a Phenom II X4 925 CPU with a Radeon HD 6670 GPU.

Flightgear runs fine with Catalyst provided by Ubuntu (2:8.960-0ubuntu1.1).

I am considering to upgrade with a R9 270X which requires Catalyst 13.12.

I'l just have to wait for this issue to be solved.

Regards.

Statistics
84201 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.