Topic Title: Catalyst and MythTV Video Accel? (Debian)
Topic Summary:
Created On: 12/22/2013 10:47 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/22/2013 10:47 PM
User is offline View Users Profile Print this message

Author Icon
Quantum
Peon

Posts: 6
Joined: 12/22/2013

Is it possible to get hardware video acceleration in Linux?  I have tried just about every setting I can think of, without success.

It seems clear that I need to enable textured video in xorg, and disable videooverlay and opengloverlay.  But no matter how I set Myth, it either gives a green screen (opengl1), a blank screen (opengl2), or plays the video with a pegged CPU (Qt).

This happens with the AMD 7990 and R9-290X, both the fastest video cards in the world.  My 7 year old nvidia 9300 was doing better than this.

I thought these cards are supposed to have hardware mpeg2 and h.264 decode?  Does it not work in the Linux proprietary driver? (v 13.8-beta1-3)

 12/23/2013 05:29 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4845
Joined: 12/27/2008

Even the open source driver is supposed to support UVD now. Something might be off with the software you're using. Contact the developer team and ask what they know about this.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 12/24/2013 12:59 PM
User is offline View Users Profile Print this message

Author Icon
Quantum
Peon

Posts: 6
Joined: 12/22/2013

I have, and their only response is 'ditch AMD and use nVidia'.  Well too late, I already have the AMD card.

I'm starting to think this may have to do with deinterlacing (is that all it can do in hardware?), but I don't know what the card will tolerate for hardware accel.

I can't believe that nothing works, and that there is no indication out there that AMD can do hardware accel with MythTV nor how to set it.  My TV has been down for days.

What have the AMD driver developers been -doing- for 2 years?  Playing Solitaire?

 

 12/25/2013 01:04 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4845
Joined: 12/27/2008

They were developing for windows, where the money comes from at the moment.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84118 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.