Topic Title: Catalyst 13.12 installation causes a black screen
Topic Summary:
Created On: 01/03/2014 11:25 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/03/2014 11:25 AM
User is offline View Users Profile Print this message

Author Icon
DJD20
Peon

Posts: 1
Joined: 01/03/2014

Hello internet, please help me.

I was running Ubuntu 13.1, when I decided to attempt to install Catalyst and the AMD-APP-SDK so I could mine for cryptocurrency more efficiently. I managed to succesfully install both programs, but when I went to reboot, all I got was "a black screen of death". 

All that appears is an error message and my cursor is an X.

I am fine switching linux OS's if that will make things easier. 

 

Please help me!

DJD20

 

PS. I am running an A8 APU and a Radeon 6670 graphics card. 

 01/14/2014 03:11 AM
User is offline View Users Profile Print this message

Author Icon
badmofo666
Peon

Posts: 7
Joined: 01/13/2014

It's usually best to install an Ubuntu package from the repository rather than from websites (the packages will usually contain older software, but the software is better tested to work with Ubuntu).

The simplest thing to do would probably be to reinstall Ubuntu, then follow the instructions to install from a package repository here:

https://help.ubuntu.com/community/BinaryDriverHowto/ATI#Installation_via_the_Ubuntu_repositories

I do not think there is a package for the AMD-APP-SDK, so you'll have to install that manually.

Also, I've had better luck (less bugs) with Debian Stable rather than Ubuntu, but the software is a little bit older than what's availabe for Ubuntu. I have succesfully mined cryptocurrency on Debian 6 and 7 with a Radeon HD 6850.

 01/14/2014 06:20 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4865
Joined: 12/27/2008

There's no need to reinstall ubuntu because of this. Boot in runlevel 1 (or 3) and execute fglrx-uninstall.sh in /usr/share/ati.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84848 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.