Topic Title: AMD Catalyst 14.1 beta or 13.12 with debian wheezy ?
Topic Summary:
Created On: 02/09/2014 05:57 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/09/2014 05:57 AM
User is offline View Users Profile Print this message

Author Icon
donna2284
Peon

Posts: 1
Joined: 02/08/2014

Has anyone successfully compiled the fglrx kernel module on debian wheezy ?

It tried vanilla kernels from 3.2 to 3.13 as well as the wheezy 3.2 kernel and the new 3.12 kernel from whezzy backports. I also tried both the driver packages from AMD (14.1beta and 13.12) and the drivers from debian.

I am not sure if there anyone out here with some knowledge on C-programming and the linux kernel, so I dont post any compiler errors yet, but if someone is interested please let me know.

 02/14/2014 01:20 AM
User is offline View Users Profile Print this message

Author Icon
terryc
Peon

Posts: 32
Joined: 10/03/2013

Compiled?

I didn't kow there was source code available.

I've download and installed various binaries with no problems. It can be finicky at first, but this was my first time for this sort of stuff and I was trying to get it run on a dual head 7790 and the fundamental X has changed.

 

I'm currently running 13.12 and had 13.11 beta9 & beta1. plus the 7790 proprietary driver of 31/9/13.

 

Where is the 14.1 driver?

 02/16/2014 04:16 AM
User is offline View Users Profile Print this message

Author Icon
Zirias
Peon

Posts: 1
Joined: 02/16/2014

Unfortunately, the drivers in debian are unusable for me. They contain (quite correctly) the latest "stable" driver, but this contains a bug (that was already fixed in an earlier beta) with the effect for me, that sometimes, closing a KDE windows crashes the whoule xserver. Thanks AMD for "quality" software and well-thought-of release process ....

 

What you can do is extract the latest beta manually and use the debian-files (with minor changes, shouldn't be a problem if you know how to build debian packages) to create your own .debs from the latest 14.1 beta. Works for me right now, it automatically uses dkms for kernel module building and installing

 

Unfortunately, I now have a different bug: Xrandr-fullscreen attempts leed to a "Bad Window" error and termination of the x client trying this. I'm so fed up with AMD (ATI!) crappy driver software, really reminds me on my first ATI video card where the windows driver showed a quite comparable quality.

 02/16/2014 09:15 AM
User is offline View Users Profile Print this message

Author Icon
bellvk219
Peon

Posts: 7
Joined: 02/16/2014

Be aware ADM has dropped LINUX support for several of thier graphics chip standards.  I have 3000 version on the motherboard of an htpc and I now have to look for a new case, larger power supply and a graphics card to get support.

AMD, you have let me down.



-------------------------

jim

 03/01/2014 03:56 PM
User is offline View Users Profile Print this message

Author Icon
sledged
Peon

Posts: 2
Joined: 03/01/2014

I was able to get them both to compile on Debian 7.4 32bit but, I cannot get either to work with my R7 260X. For my compile issue, the failure is in file kcl_iommu.c. User Jean-Marc Liotier at the Debian user gorup provided the fix in message 88 on bug 729765. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=729765#88

That fixed my compile issue but my R7 260X still does not work under Debian 7.4. Jean-Marc indicated the following was required before a reboot to get his setup working. "dpkg-reconfigure fglrx-modules-dkms"

The dpkg  fails indicating a problem because it appears to be a binary. Once I get the clean compile I'm not sure what to do with the files. The Catalyst installer doesn't work as it overwrites the fix. Debian user gindek supplied the answer in his orginal post on the debian user group on how to install.

0. Uninstall old driver installation: /usr/share/ati/fglrx-uninstall.sh --force  && reboot
1. Extract driver: ./amd_driver.run --extract amd-driver
2. Apply patch kcl_iommu.c 
3. ./ati-installer.sh 13.20.16 --install  (parameters taken from watch "ps aux | grep ati-instller"

I will try this at my first opportunity and report back.

The issue I see after a fresh Debian 7.4  install is, the screen goes black when I log in. Up to that point it is working fine. Prior to the r7, when I log in the first time I get an error message indicating a problem with GDM3 and it tells me it is reverting back. Then, I install the default catalyst driver from Debian and everything works fine on an HD5450. I suspect the failure is based on the debian default drivers not supporting the r7 but that is just speculation.This is what led me down the path of trying the Catalyst install. Stay tuned.

sledge



Edited: 03/01/2014 at 04:24 PM by sledged
Statistics
84327 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.