Topic Title: fglrx impossible with Asus r9 280x
Topic Summary:
Created On: 03/06/2014 10:38 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/06/2014 10:38 PM
User is offline View Users Profile Print this message

Author Icon
dstanescu
Peon

Posts: 4
Joined: 03/06/2014

Hi, i own 2x Asus r9 280x (r9280x-dc2-3gd5) which i'm trying to install the drivers on linux, for about 1 week (16-18h/day).

I tried everything i could think of with no success.

I tried Catalyst: 13.1, 13.4, 13.11-b9.4, 13.11-b9.95, 13.12, 14.1-b1.3, 14.2-b1.4 (the latest beta)

on almoast every linux distro: Ubuntu 11.04/11.10/12.04/12.10/13.04/13.10/14.04, Fedora 18/19/20, CentOs 6.3/6.4/6.5, RedHat 6.5, Debian 6.0/7, Suse 11, OpenSuse 13

and no success, only a lot of wasted time.

What happens watching xorg.log: sometimes fglrx crashes, sometimes it just hangs with no output, sometimes recognizes 1 card and with the other it hangs again and other times no errors nothing but xorg doesn't start, he hangs too.

I tried everything including some patches to fglrx found on google nothing. On each distro i tried each version of catalyst. The same system (hardware+software) works with another card for ex r9 290 but not with this 280x. On the same system i installed windows and saw the drivers works as expected (so no hardware issue, the only cause is fglrx) but on linux what is happening? The drivers aren't updated/fixed in both places? The open source drivers from Ubuntu for ex works (are not good for me, i need fglrx) but if i try to install the proprietary drivers from them again doesn't work. So fglrx it just doesn't want to work with this card!

If anybody can help me in some way with a solution pls, i'm desperate!

It's impossible for me to understand how a huge company like Amd which is nr 1 on gpu's and not only doesn't have working drivers for his chips.

How we (consumers) are supposed to use them? I spent a lot of money on this boards and i'm only staring at them. Big disappointment!

 03/19/2014 11:55 PM
User is offline View Users Profile Print this message

Author Icon
blairfus
Peon

Posts: 3
Joined: 03/19/2014

Sorry if this is basic, but others may be having a similar issue, and if this works for you, hopefully they'll be able to follow it as well.

tl;dr:  Install from packages built from the driver binary for your distribution.

Choose a distro. I use ElementaryOS which is built around Ubuntu 12.04 LTS. I also installed a 3.11.0 kernel backported from the Saucy repo, so what I recommend will be based on the assumption of running an Ubuntu or Debian based distro. I'm currently using Catalyst 14.3 Beta v1.0 on it with no issues. Update and upgrade your distro, then install the typical build essential packages.

Since Catalyst 13.11, I've only had success installing the drivers from packages built for my distro. Installing directly from the binary almost always breaks everything, the patches don't work, and the packages are simpler to install and remove anyway.

To build the packages, in a terminal, execute the driver binary with the --listpkg option, copy the distro your kernel is based on from the list, then execute it again with --buildpkg=[distro from list]. When it's done, use dpkg -i (or your distro's package installer) on the generated files to install them.

Look for any errors, and download any dependencies. You may have to install the fglrx_* before the fglrx-* packages. After they've all installed properly, execute aticonfig --initial, then reboot.

If it reboots into a black screen, try to ctrl+alt+F1 into a TTY to read through the logs or to uninstall the fglrx* package files, and then delete your /etc/X11/xorg.conf. Reboot. It should load your usual graphical DE. If you're not feeling too defeated, you can try installing some prebuilt packages from your distro's software center.

The last time I let my distro install my graphics drivers was several years ago on Linux Mint through its Driver Manager, which worked well, although the version installed was a little out of date. I imagine most modern repos should have something similar (Additional Drivers? Software Center?) for installing fglrx packages. Try searching for fglrx and installing what you find.

If that works, congratulations, take a break. You can look for more answers later. If it doesn't, at least you tried.

Statistics
84960 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.