Topic Title: How do I get the temperature readings for R9 290?
Topic Summary:
Created On: 03/29/2014 12:46 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/29/2014 12:46 PM
User is offline View Users Profile Print this message

Author Icon
tunage
Peon

Posts: 27
Joined: 03/29/2014

coinbox2 home # DISPLAY=:0 aticonfig --adapter=0 --od-gettemperature

ERROR - Get temperature failed for Adapter 0 - Supported device 67B1

 

 

coinbox2 home # fglrxinfo

display: :0  screen: 0

OpenGL vendor string: Advanced Micro Devices, Inc.

OpenGL renderer string: HAWAII PRO (67B1)

OpenGL version string: 4.2.12422 Compatibility Profile Context 13.35.1005

coinbox2 home # acpi -t
Thermal 0: ok, 29.8 degrees C
Thermal 1: ok, 27.8 degrees C
coinbox2 ~ # aticonfig --list-adapters
* 0. 01:00.0 Supported device 67B1
  1. 04:00.0 Supported device 67B1
  2. 05:00.0 Supported device 67B1
  3. 06:00.0 Supported device 67B1
aticonfig --adapter=ALL --initial
 03/30/2014 10:03 AM
User is offline View Users Profile Print this message

Author Icon
tunage
Peon

Posts: 27
Joined: 03/29/2014

I am running Gentoo on a headless box, 2133 mh ddr3 Patriot RAm with a 1500 watt ps

 03/30/2014 09:24 PM
User is offline View Users Profile Print this message

Author Icon
tunage
Peon

Posts: 27
Joined: 03/29/2014

anyone?

 03/30/2014 10:59 PM
User is offline View Users Profile Print this message

Author Icon
Thanny
Elite

Posts: 1296
Joined: 07/13/2009

Not many linux users here, and even fewer people who waste time calculating fake currency.

You didn't specify which version of ati-drivers you have installed.  Obviously the version you do have doesn't support reading R9 temperatures.  Try emerging ati-drivers with the experimental keyword e.g. ~amd64) for your platform to get the latest beta driver.

 

 03/31/2014 12:15 AM
User is offline View Users Profile Print this message

Author Icon
tunage
Peon

Posts: 27
Joined: 03/29/2014

fglrx-13.35.1005

and the gentoo default drivers provided via the portage package management.

 03/31/2014 11:02 PM
User is offline View Users Profile Print this message

Author Icon
terryc
Peon

Posts: 32
Joined: 10/03/2013

will psensor solve your problem?

You can run a server remotely on te logged machine and psensor --url//remote-machine.

Something in man sensor to read first about a driver in /usr/lib and compilig it under the ati sdk.

Statistics
84124 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.