Topic Title: Setup 2 HD6670 with 3 display on Linux Fedora 20 with xrandr
Topic Summary: Problems setting up 2 HD6670 and 3 displays
Created On: 05/28/2014 03:05 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/28/2014 03:05 PM
User is offline View Users Profile Print this message

Author Icon
catzilla
Peon

Posts: 3
Joined: 05/28/2014

I'm trying to set up a system running Fedora 20 64 bit with 2 HD6670 display cards and 3 displays. I have never been able to get this to work unless I configure xorg.conf to enable the Xinerama extension. I just installed the latest beta drivers (14.2) and it still does not work.

I should be able to make this work using  xrandr 1.4, but when I run 'xrandr --listproviders' the response is that there are no providers.

I tried this setup using the radeon open source driver and issuing xrandr commands to combine the three displays butb there are two problems. First, the display is unacceptably sluggish on an Intel i7 SandyBridge system. Second, I cannot run the AMD OpenCL software with the radeon drivers.

How do I set up this system so I can use all three displays as a single desktop and not need to use the Xinerama extension?

 05/29/2014 05:38 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4846
Joined: 12/27/2008

1. The latest beta is not 14.2 but 14.6. It has just been relesed recently.

2. Fedora and AMD is a no-go. The fedora kernel is f.....ud up and doesn't work with Catalyst. Switch to *buntu or anything but Fedora.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 05/31/2014 10:54 AM
User is offline View Users Profile Print this message

Author Icon
catzilla
Peon

Posts: 3
Joined: 05/28/2014

Well, I spent a day installing an Ubuntu 14.04 partiton and installing the latest AMD beta driver. Ubuntu is even more screwed up.

I ran amdcccle and made sure Xinerama was off. I ran 'xrandr --listproviders' and *still* get zero providers.

I stil cannot configure a triple display desktop. I can get two displays on one card to work as multi-display desktop with 2 displays but the third display can only be configured as a single display desktop.

When I restart the Desktop manager, the dual displays work but nothing displays on the third desktop.

If I turn on the Xinerama option, then all three displays come up but as soon as I start the desktop manager, something is hung and I cannot get any response from the desktop.

 

Now what?

 05/31/2014 01:10 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4846
Joined: 12/27/2008

There is only one thing I can think of.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 05/31/2014 01:20 PM
User is offline View Users Profile Print this message

Author Icon
catzilla
Peon

Posts: 3
Joined: 05/28/2014

Ok, thanks. Somehow I missed that link. The forum link brings me back here. Maybe I need to investigate the Eyefinity options.



Edited: 05/31/2014 at 01:29 PM by catzilla
Statistics
84153 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.