Topic Title: VSYNC - Top 1/4th of screen does not sync!
Topic Summary: Screen tearing w/ multiple cards, distros. Do not want tearfree
Created On: 05/30/2014 12:25 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/30/2014 12:25 AM
User is offline View Users Profile Print this message

Author Icon
epsilon72
Peon

Posts: 3
Joined: 05/30/2014

I've recently defected from the Green camp with a recently acquired R9 290, and it has been okay so far except for one BIG, frustrating problem:

The top 1/4th or so of the screen will not sync when vsync is enabled.  This happens with Unity, GNOME 3, and multiple games (Sword & Sworcery and Darwinia to name two).  It may happen in KDE as well but I do not have it installed to test with...

*Monitors tested:

Dell u2410 (1920x1200) (DVI, DP)

ASUS VH226H (1920x1080) (DVI)

Some old LCD monitor (1280x1024) (DVI)

**Distros tested:

Debian wheezy

Debian jessie

Ubuntu 13.10

Gentoo

****GPU's tested:

XFX 5450

HIS 7790

Gigabyte R9 290

*****FGLRX versions tested:

13.9

13.12

14.4

 

I've had the same issue with all of the above test conditions.  I've poked around for hours trying to find a solution, but nothing has worked yet, except for running 

compton  --backend glx --vsync opengl-swc --paint-on-overlay

...but that isn't an option with GNOME 3 or Unity, because they use their own compositors.

It is mentioned by the OP in this thread as well (3rd point): 

http://forums.amd.com/game/messageview.cfm?catid=488&threadid=173223&highlight_key=y&keyword1=vsync

I do not want to use Tear Free because it is laggy and crash-prone in my experience.  Is anyone else experiencing this?



Edited: 05/30/2014 at 01:10 AM by epsilon72
 05/30/2014 09:50 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4861
Joined: 12/27/2008

My trick is enabling tearfree first, then going to 3d settings and changing the vsync setting back to off unless application specifies. This was I can get the best of both worlds, a nice desktop experience (including video playback) and still not having to use input lag (I mean vsync) in games.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 05/30/2014 09:59 AM
User is offline View Users Profile Print this message

Author Icon
epsilon72
Peon

Posts: 3
Joined: 05/30/2014

I'll have to try that when I get home from work, although my gut feeling says that there will probably be some input lag though.  I like to play fps's and vsync along with my u2410 makes them very difficult to play due to input lag.

That, and tearfree has a bad habit of crashing X, especially when wine or VLC is involved...

I will post results later.

 05/30/2014 08:06 PM
User is offline View Users Profile Print this message

Author Icon
epsilon72
Peon

Posts: 3
Joined: 05/30/2014

It looks like input lag with tearfree is reduced vs. input lag with plain vsync, but there still is a noticeable difference compared to no vsync/no tearfree enabled whatsoever.

Is the "top of the screen sync" problem pretty common, with most people just enabling tearfree to get around it?  Or is it not a problem for the majority of radeon owners? 

Statistics
84706 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.