Topic Title: Kaveri + Catalysttm for Linux + Kernel 3.13
Topic Summary:
Created On: 06/23/2014 05:09 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/23/2014 05:09 PM
User is offline View Users Profile Print this message

Author Icon
Dekoski
Peon

Posts: 2
Joined: 06/23/2014

I have a Kaveri APU (A10-7850K), and the only way to install Kubuntu is with "nomodeset" flag, and this way the radeon driver module cant use OpenGL.

After installing kubuntu I've tried with fglrx, fglrx-updates, and AMD's website 14.4 and 14.6 Beta. Always with a black screen and no possibility to open a text terminal (ctrl-alt-f2), just a hard reset works.

 

Any idea will be appreciated.

 06/24/2014 12:28 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

According to Phoronix your APU should work fine under 14.04. Michael used a different driver though, so try to find that one. I don't know if it's available anywhere, google it.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 06/26/2014 11:33 PM
User is offline View Users Profile Print this message

Author Icon
Darksurf
Peon

Posts: 6
Joined: 02/13/2014

I'm using fglrx 14.6beta with my A10-7850K perfectly fine. I'm using sabayon. My main issue is that AMD wont %^&#*ing fix Hybrid Crossfire!!!! Its greyed out and if you attempt to enable it manually it says:

 

darksurf@sabayon ~ $ aticonfig --cf=on --adapter=0,1

Warning: No MGPU chain defined for master adapter 0

Crossfire chain(s) enabled

CrossFire does not support on this platform

Warning: X needs to be restarted before CrossFire changes take effect.

BULL%^&* !!! I know for 100% of a fact it is supported! I can't believe I payed $1000 to make a steambox rig and AMD is screwing me with their crappy drivers!
 06/27/2014 01:21 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

You have your own thread, why hijack this one?



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 06/27/2014 08:14 AM
User is offline View Users Profile Print this message

Author Icon
Dekoski
Peon

Posts: 2
Joined: 06/23/2014

I have tried all Catalyst versions I've found on internet without success.

I think this is will be the last AMD I build. 

Statistics
86403 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.