Topic Title: Poor performance Witcher 2 // Natural selection 2 ubuntu 7970m
Topic Summary:
Created On: 07/06/2014 10:56 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/06/2014 10:56 AM
User is offline View Users Profile Print this message

Author Icon
StarAurryon
Peon

Posts: 5
Joined: 07/06/2014

Hi

I have an issue about gaming performance with theses two games. Same category NVIDIA graphics card can handle with ease theses games. It's not the case with my AMD.

Please enhance and fix theses games.

StarAurryon

Ubuntu 14.04 MSI GX60 3AE

 07/06/2014 03:29 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4883
Joined: 12/27/2008

What CPU do you have? The witcher 2 mostly requires a super powerful CPU with super powerful single threaded performance, as it runs a compatibility layer and runs it on a single thread. You need a top i5 or even an i7 to get something close to playable out of the game.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 07/08/2014 06:32 AM
User is offline View Users Profile Print this message

Author Icon
StarAurryon
Peon

Posts: 5
Joined: 07/06/2014

It might be my processor for the witcher but for NS2 I have only 22 fps on Full HD whereas in windows i get 55. NVIDIA users with 650 can play with ease this game on linux which is not the case with a more powerful 7970m (pitcairn=underclock 7870).

 07/08/2014 07:09 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4883
Joined: 12/27/2008

Unfortunately I can't comment about NS as I  don't know anything about it. If you're sure that it's a driver problem, and it should run better, you should submit a bug report.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84960 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.