Topic Title: Problems running Dolphin emulator
Topic Summary:
Created On: 07/06/2014 04:56 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/06/2014 04:56 PM
User is offline View Users Profile Print this message

Author Icon
GoldenStake
Peon

Posts: 1
Joined: 07/06/2014

I am trying to run Dolphin, a Wii and GC emulator, on my computer
I have everything set up, but when I go to launch any game, the screen begins to display what I would describe as a graphical hurricane.
A huge jumble of polygons of seemingly correct colors for what screen it should be on ( screen shot at bottom)
The incoming sounds are accurate, and I can blindly navigate the menus.

I've installed and compiled the dolphin from their git repository https://github.com/dolphin-emu/dolphin

My computer is a Linux build, running Ubuntu 14.04 x64
Processor is Intel i5 (Gen 1, Sandy Bridge I think)

my graphics card is an ATI Radeon HD 78xx
I am running the proprietary fglrx drivers version 14.6 Beta
I believe the catalyst version is 14.20

here is my fglrxinfo
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7800 Series
OpenGL version string: 4.4.12967 Compatibility Profile Context 14.20

And I've created a log dump from dolphin
http://pastebin.com/WLCMCWK4

Thanks for any suggestions


 07/07/2014 05:41 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4860
Joined: 12/27/2008

I hate saying this, but the 14.x drivers are utter crap. They have some serious threading bugs in them, they can't even run Doom 3 and Quake 4, not to mention Dolphin...

I suggest you try some 13.x drivers with some older linux distro. I remember using Dolphin on linux successfully and even performance was good, though I had some sound problem because of little crappy pulseaudio and had to switch to the windows version.

And one more thing, the most important one: http://www.amd.com/linuxreport



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84661 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.