Topic Title: 5350 APU graphics problems with Linux
Topic Summary: Problems with Catalyst and open source drivers.
Created On: 07/14/2014 10:59 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/14/2014 10:59 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 07/14/2014

I have the following hardware:

AMD 5350 Athlon APU

Asus AM1i-a mini itx board

16 GB memory

I have tried Ubunutu, Mint, Mint Debian, OpenSuse, and Manjaro - all have the same problems with both graphics drivers.  The Catalyst driver leaves artifacts and has other odd problems.  The open source driver works great for about 30 minutes, then the mouse begins slowing down, videos hang, the screen will freeze, and then finally a black screen on both monitors.  Audio will continue to play and after about 30 seconds, the video output returns, but it will continue to happen every few minutes after that.  

I tried adding a fan, but the temps were never too high to begin with.  Anybody have any ideas? 

 07/14/2014 03:31 PM
User is offline View Users Profile Print this message

Author Icon
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Install a trial version of windows and check out how it behaves there. If you experience issues, you need to RMA the APU. If not, keep on reporting bugs until they get fixed.


CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

92917 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.