Topic Title: No AMD graphics driver?
Topic Summary: can I get some help?
Created On: 05/02/2014 03:24 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/02/2014 03:24 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 05/02/2014

Hi guys

Im new to this forum and have decided to give it a shot. 

I just finished updating my Razer Naga software and were about to restart the computer like it asked me to do when whe mouse AND the keyboard stopped working. The only way to restart the computer after that was to press the restart button onfront of it. When it turned back on everything was huge and neither my mouse nor keyboard worked and I got the message 

"No AMD graphics driver is instelled, or the AMD driver is not functioning properly. Please install the AMD driver appropriate "

There is no way the mouse or the keyboard works, so what can I do? I  can only get the mouse to work when I press F11 when I turn on the computer and enter the motherboad. If anyone could be so kind and tell me step by step how to fix this it would be appreciated




ps. sorry for my poor english

 05/02/2014 04:34 PM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8827
Joined: 11/13/2009

If you do a google search for 'razer naga software problems' you will find 114,008 pages dating back years. All, including the logitech site, have solved it by deleting/disabling the software. Logitech has a history of crappy controllers that cause the symptoms you have described. The mouse/keyboards are fine...but let Windows manage it.


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 05/02/2014 04:59 PM
User is offline View Users Profile Print this message

Author Icon
80 Column Mind

Posts: 13562
Joined: 04/17/2008

Contact Razer, perhaps there is a firmware update for it.

AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970 GHz Edition, 1TB Samsung 850 Evo, 256GB OCZ Vector, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ult Ed x64
93404 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.