Topic Title: Notebook uses onboard video card instead of AMD
Topic Summary:
Created On: 12/12/2013 11:03 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/12/2013 11:03 AM
User is offline View Users Profile Print this message

Author Icon
JTUnhold
Peon

Posts: 4
Joined: 12/12/2013

I experienced this problem when playing Skyrim via Steam. I wasn't able to select the AMD card, only Intel. No effect after chosing high quality/performance for Skyrim in the Control Center. Even when I chose very high quality in the game, it is very bad. With medium quality it doesn't work fluently. My conclusion: the game does not use the AMD video card. What can I do to change this?

My notebook: Acer E1-572G with switchable graphics, i5-4200U ...

I bought it 1 week before...

Graphics Card
- AMD Radeon HD 8750M (2GB) and onboard Intel HD 4400 -> both are displayed as functioning


AMD Catalyst Driver Version, and Driver History
- driver version Intel: 9.18.10.3234, driver version AMD: 12.100.14.3000

- other versions (including newest) of both Intel and AMD were tested

- currently, after installing other drivers and also with the newly installed original drivers - they don't seem to work together: Catalyst Control won't open

Operating System
- 64-bit Windows 8
- Windows 7 not tested so notebook can be brought back to the store

Applications and Games

- Skyrim via Steam

- Spellforce 2 via CD (not sure, but it's not working well either)

System Memory Type & Amount
- 4GB DDR3 L Memory

Additional Details
- virus check: McAfee (was installed)

- one time restored to factory settings because recommended by Acer support - don't want to do it again, takes ages -.-"

- I contacted Acer and Bethesda before, no help from these sides.

I would be very glad if you could help me I need to know if it's the notebook's fault or mine

 12/12/2013 11:28 AM
User is offline View Users Profile Print this message

Author Icon
zipsi
Elite

Posts: 1037
Joined: 11/22/2010

Can you disable the onboard gpu from bios? It can be done on a desktop, but I'm not sure if that option is present in a laptop bios.



-------------------------
Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, Samsung 840 Pro 256gb, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
 12/13/2013 10:14 AM
User is offline View Users Profile Print this message

Author Icon
JTUnhold
Peon

Posts: 4
Joined: 12/12/2013

I disabled the onboard card with the device manager, not in bios. But it had no effect. And Acer support said i shouldn't do this because the 2 video cards need to work together. Do you think it would be different in bios? (how do you get there in Windows 8? ^^)

 12/13/2013 10:52 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7169
Joined: 11/13/2009

Acer support is not the best in the world...I do not know how to get into the bios of Windows 8, but it should be similar to any other...that is press the f2 key as the computer boots up. But you can google or ask Acer. Once in the bios, if your laptop has this feature, you have a choice of using 'dynamic' or 'fixed' graphics. The wording may be different but the choice should be obvious. Selecting the 'fixed' setting disables the on-board (weak) graphics and uses the stronger graphics all the time.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/14/2013 06:58 AM
User is offline View Users Profile Print this message

Author Icon
JTUnhold
Peon

Posts: 4
Joined: 12/12/2013

Ok, i didn't find anything like that in bios. Maybe I'm too stupid or maybe it's just not there, can't tell ><

Thank you for your answers so far. I'm thinking about giving money to anyone with a permanent solution. Really.



Edited: 12/14/2013 at 08:01 AM by JTUnhold
 12/14/2013 07:29 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7169
Joined: 11/13/2009

Read this article ..>HERE< . Even though it's not your brand of laptop...the mechanics are similar.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84670 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.