Topic Title: Current drivers + Windows 8.1 + fn Bright key = Dont work
Topic Summary: AMD Mobility HD5800 Series on windows 8.1 Pro x64
Created On: 02/22/2014 08:40 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/22/2014 08:40 PM
User is offline View Users Profile Print this message

Author Icon
CharfatoS
Peon

Posts: 7
Joined: 02/22/2014

Hi, im user of a ASUS G73JH-B1 Laptop, wich have ATi 5870m display adapter... I allways used Windows 7 HP x64, until last week i get a licence for Windows 8.1 Pro x64, so... I installed it from clean, and fix some isues of freezing and problematic drivers, and actually all works perfect! :D

Now the PROBLEM, last weekend i notice that the Fn for Brightness dont work properly (ONLY THAT ONE), so i check anr re-check ATTK driver but the problem was not there... So, i roll back my Video Drivers from 14.1 BETA to current stable 13.12 but nothing changes... Now, i repeat the procces SEVERLY TIMES, and make a progress in the 13.4 when the Fn key WORKS!! :D ... But the games and Windows in general freeze and the performance got so down low, that i just go back to 13.12 and stay...

 

So i want with this post report this problem, and thats all :3

PS1. Sorry for my gramma and bad english, its not  my native language ;)

PS2. All my drivers are up to date (Without report of any warning or error events), Intel inf and other stuff working really fine after almost two weeks of suffering and figthing with Windows 8.1 Pro x64 clean install.

PS3. System Specs:

- ASUS Laptop model G73JH-B1 (With lastes BIOS)
- Windows 8.1 Pro x64 (Clean Install)
- AMD/ATI Radeon HD 5870m
- i7 740QM
- 8GB RAM 

 02/22/2014 09:40 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7269
Joined: 11/13/2009

Use the issue report form

http://support.amd.com/en-us/download



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 02/23/2014 12:06 AM
User is offline View Users Profile Print this message

Author Icon
CharfatoS
Peon

Posts: 7
Joined: 02/22/2014

i almost do it, but then i notice that form its focused for Desktop gama... So i pass by to this forums



Edited: 02/23/2014 at 12:21 AM by CharfatoS
 02/23/2014 03:12 AM
User is offline View Users Profile Print this message

Author Icon
Gultan
Peon

Posts: 1
Joined: 02/23/2014

I installed then after every Restart the "Display screen brightness" switch back to (0)nill & can't control it anymore and i uninstalled all video drivers including Intel then Reinstalled d catalyst mobility drivers (any ver)same issue .. done many times :"( no use .. also my performance got slow.

So everytime when i Boot my laptop HP dv6ex6092 > i have to disable & enable d AMD display adapter frm "Device Manager" to have proper brightness. It is such a pain .. But i really do appreciate the hardwork of Developers (Y) Hope they solve this issue soon. Thank YOU!! 

Platform: Windows 8.1 Enterprise x64

Graphic: AMD Radeon HD 6700M series & Intel HD graphics 3000.

 02/23/2014 03:58 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7269
Joined: 11/13/2009

Many times this has been mentioned. It is a issue with Asus laptops. Roll back to the drivers that worked for you. Read the forum posts for similar/identical issues.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 02/23/2014 11:13 AM
User is offline View Users Profile Print this message

Author Icon
Xellon
Peon

Posts: 33
Joined: 01/22/2014

Messing with drivers/doing clean installs will kill your lights and it won't come back on no matter what drivers you install.

 

Your gonna need to flash your Bios (which it looks like you did) and Vbios (if you haven't). Learn how on google. Download the latest bios from asus site. Download the Vbios off the notebook review forums. I believe there were 2, 1 made by asus reps, another made my Chastity, a member on the forums who added overclocking on the ati control panel. I never used it but i heard both works well.

 

This fixes your light issues, fan speed issues, gsod issues and monor toucpad issues. If your lights do not come on after a vbios update, make sure you have the stock atk drivers installed.

 

Also when you power on your laptop, if your lights do not blink once as windows load, you have a hardware issue (no biggie, can be re-wired).

 

To completly fix your touchpad, you will need to open up your laptop (yes, it is a pain to do and theirs a tutorial on it) and remove the matalic sticker covering the inside of the touchpad.

 

The G73 had overheating issues for some of them, I was lucky enough to not have any issues with heating (83c or lower for gpu and 85c lower for cpu when stressing the cpu/gpu, very good temps). This is with stock thermal.

 

I think I covered all the issues on the g73 for ya. Good luck.

 

edit - Oh, btw, make sure you have turbo boost disabled when gaming as it performs better. Turbo boost comes in handy during certain situations such as recording while gaming or using emulators.



-------------------------

Asus G73jh-A1 ~ Windows 7 64 Bit ~ I7-720Qm ~ ATI 5870M (Sometimes OC to  780/1075) ~ 8 Gigs Ram ~ SSD



Edited: 02/23/2014 at 11:21 AM by Xellon
 02/23/2014 01:25 PM
User is offline View Users Profile Print this message

Author Icon
CharfatoS
Peon

Posts: 7
Joined: 02/22/2014

Originally posted by: Xellon Messing with drivers/doing clean installs will kill your lights and it won't come back on no matter what drivers you install.

 

 

 

Your gonna need to flash your Bios (which it looks like you did) and Vbios (if you haven't). Learn how on google. Download the latest bios from asus site. Download the Vbios off the notebook review forums. I believe there were 2, 1 made by asus reps, another made my Chastity, a member on the forums who added overclocking on the ati control panel. I never used it but i heard both works well.

 

 

 

This fixes your light issues, fan speed issues, gsod issues and monor toucpad issues. If your lights do not come on after a vbios update, make sure you have the stock atk drivers installed.

 

 

 

Also when you power on your laptop, if your lights do not blink once as windows load, you have a hardware issue (no biggie, can be re-wired).

 

 

 

To completly fix your touchpad, you will need to open up your laptop (yes, it is a pain to do and theirs a tutorial on it) and remove the matalic sticker covering the inside of the touchpad.

 

 

 

The G73 had overheating issues for some of them, I was lucky enough to not have any issues with heating (83c or lower for gpu and 85c lower for cpu when stressing the cpu/gpu, very good temps). This is with stock thermal.

 

 

 

I think I covered all the issues on the g73 for ya. Good luck.

 

 

 

edit - Oh, btw, make sure you have turbo boost disabled when gaming as it performs better. Turbo boost comes in handy during certain situations such as recording while gaming or using emulators.

 

Hi Xellon, my laptop have all this issues covered already (The first year when i bought it) with VBios of Chassity or the Catalyst Maker (I dont remember wich one, but corrects the defects) wich works perfect with the 10.2+ Catalyst and so far the lastest Beta drivers (before that was no possible)...

Unfortunaly, if i downgrade the Driver a little bit, Windows 8.1 start to freeze or the Catalyst make problems to itself, and if i downgrade more and more, my games stop working (BF4, FFXIV, etc) not all of them like the old ones... So, this make ussles my laptop and i prefer not have the Fn Bright control fully operationally, and gaming like a normal person

 

PS1. My problem only its with Windows 8.1 + Drivers + Fn bright key... Allt he rest of the components (Drivers and software) are compatible and checked several times with no Events reporting

PS. I check an re-check all the stuffs and the problem its linking Windows 8.1 (IDK if Windows 8 works because i start from 8.1) with AMD Drivers and then the ATTK pakage make works the Fn button (Without ATTK any of the Fn works, and was the only version that works without Freeze problems).

 02/23/2014 03:47 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7269
Joined: 11/13/2009

The 13.4 drivers are the latest ones that will work with Asus laptops. There is nothing wrong with your keys or computer. The versions after 13.4 causes the isssues you are reporting. I am using the 13.9 and it works only with a external monitor. That's the bottom line. Plug in a monitor and you can use any version driver. It has been reported to AMD but I don't know if anyone reported to Asus.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 02/23/2014 04:02 PM
User is offline View Users Profile Print this message

Author Icon
CharfatoS
Peon

Posts: 7
Joined: 02/22/2014

Originally posted by: stumped The 13.4 drivers are the latest ones that will work with Asus laptops. There is nothing wrong with your keys or computer. The versions after 13.4 causes the isssues you are reporting. I am using the 13.9 and it works only with a external monitor. That's the bottom line. Plug in a monitor and you can use any version driver. It has been reported to AMD but I don't know if anyone reported to Asus.

 

Hi and thanks for your atention and suggestions ... I will try 13.4 and make some feedback (im not sure if i already done it with that version)... I assume you mean the Fn Brightness key issue only

 02/23/2014 04:55 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7269
Joined: 11/13/2009

Originally posted by: CharfatoS
Originally posted by: stumped The 13.4 drivers are the latest ones that will work with Asus laptops. There is nothing wrong with your keys or computer. The versions after 13.4 causes the isssues you are reporting. I am using the 13.9 and it works only with a external monitor. That's the bottom line. Plug in a monitor and you can use any version driver. It has been reported to AMD but I don't know if anyone reported to Asus.

 

 Hi and thanks for your atention and suggestions ... I will try 13.4 and make some feedback (im not sure if i already done it with that version)... I assume you mean the Fn Brightness key issue only

For most users with this problem, it is more than just the Fn issue....the screen is totally dark. It seems to only affect Asus laptops. Just for grins, if you have access to a monitor, plug it in and see if it works.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 02/23/2014 05:01 PM
User is offline View Users Profile Print this message

Author Icon
CharfatoS
Peon

Posts: 7
Joined: 02/22/2014

Originally posted by: stumped
Originally posted by: CharfatoS
Originally posted by: stumped The 13.4 drivers are the latest ones that will work with Asus laptops. There is nothing wrong with your keys or computer. The versions after 13.4 causes the isssues you are reporting. I am using the 13.9 and it works only with a external monitor. That's the bottom line. Plug in a monitor and you can use any version driver. It has been reported to AMD but I don't know if anyone reported to Asus.

 

 

 

 

 Hi and thanks for your atention and suggestions ... I will try 13.4 and make some feedback (im not sure if i already done it with that version)... I assume you mean the Fn Brightness key issue only

 

 

For most users with this problem, it is more than just the Fn issue....the screen is totally dark. It seems to only affect Asus laptops. Just for grins, if you have access to a monitor, plug it in and see if it works.

 

 

Often i use a SONY Bravia for movies via HDMI, but all its the same including the Fn Brightness key broplem, so im sure its Driver + Windows 8.1 relationship

 02/23/2014 05:08 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7269
Joined: 11/13/2009

Did you check with Asus to see if that laptop will support Win8.1 ? Not all do (regardless of what Micro$oft says)...some that will support Win8 will not support Win8.1. I( would check with Asus first, if they say the laptop will support Win8.1 they will have drivers for it. Use them . Also check for bios updates.

edit: These are the Asus laptop models that support a upgrade to Win8.1

Notebook Model Name OS Update to Windows 8.1
B43A 64bit
B43V 64bit
B53A 64bit
B53V 64bit
G46VW 64bit
G55VW 64bit
G75VW 64bit
G75VX 64bit
ASUS_ROG_G750JW 64bit
K46CA 64bit
K46CB 64bit
K55VD 64bit
K56CA 64bit
K56CB 64bit
K56CM 64bit
N46VB 64bit
N46VJ 64bit
N46VZ 64bit
N56VZ 64bit
N56DP 64bit
N56DY 64bit
N56VJ 64bit
N76VB 64bit
N76VJ 64bit
N76VZ 64bit
N56VB 64bit
ASUS_VivoBook_S300CA 64bit
ASUS_VivoBook_S400CA 64bit
ASUS_VivoBook_S550CA 64bit
ASUS_VivoBook_S550CB 64bit
ASUS_VivoBook_S550CM 64bit
TAICHI21 64bit
TAICHI31 64bit
U38DT 64bit
U38N 64bit
U45U 64bit
U47A 64bit
U47VC 64bit
UX21A 64bit
UX31A 64bit
UX32A 64bit
UX32VD 64bit
UX42VS 64bit
UX51VZ 64bit
UX51VZH 64bit
UX52VS 64bit
X200CA 64bit
X200CA Touch 64bit
X202E 64bit
X301A 64bit
X45A 64bit
X401U 64bit
X402CA 64bit
X45C 64bit
X401A 64bit
X450CA 64bit
X450CC 64bit
X451CA 64bit
X501A 64bit
X501U 64bit
X502CA 64bit
X55A 64bit
X55A 64bit
X55U 64bit
X550CA Touch 64bit
X550VB 64bit
X55A 64bit
X55C 64bit
X55VD 64bit
X75VB 64bit
X550CA 64bit
X550VB 64bit
X550VC



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *



Edited: 02/23/2014 at 05:54 PM by stumped
 02/23/2014 05:56 PM
User is offline View Users Profile Print this message

Author Icon
CharfatoS
Peon

Posts: 7
Joined: 02/22/2014

No, the laptop comes with W7 HP x64, but two weeks ago i get a licence for W8.1 Pro x64, so i make a clean install of the sistem... When i use the Driver from ASUS for my laptop model, the system get random freezes and crashes (its to old, like 10.2) + some games dont work D:

 

So i will find the correct driver anytime, i think D:

 02/23/2014 06:10 PM
User is offline View Users Profile Print this message

Author Icon
CharfatoS
Peon

Posts: 7
Joined: 02/22/2014

Originally posted by: stumped Did you check with Asus to see if that laptop will support Win8.1 ? Not all do (regardless of what Micro$oft says)...some that will support Win8 will not support Win8.1. I( would check with Asus first, if they say the laptop will support Win8.1 they will have drivers for it. Use them . Also check for bios updates.

 

edit: These are the Asus laptop models that support a upgrade to Win8.1

 

Notebook Model Name OS Update to Windows 8.1
B43A 64bit 
B43V 64bit 
B53A 64bit 
B53V 64bit
G46VW 64bit  
G55VW 64bit  
G75VW 64bit  
G75VX 64bit  
ASUS_ROG_G750JW 64bit  
K46CA 64bit  
K46CB 64bit  
K55VD 64bit  
K56CA 64bit  
K56CB 64bit  
K56CM 64bit  
N46VB 64bit  
N46VJ 64bit  
N46VZ 64bit  
N56VZ 64bit  
N56DP 64bit  
N56DY 64bit  
N56VJ 64bit  
N76VB 64bit  
N76VJ 64bit  
N76VZ 64bit  
N56VB 64bit  
ASUS_VivoBook_S300CA 64bit  
ASUS_VivoBook_S400CA 64bit  
ASUS_VivoBook_S550CA 64bit  
ASUS_VivoBook_S550CB 64bit  
ASUS_VivoBook_S550CM 64bit  
TAICHI21 64bit  
TAICHI31 64bit  
U38DT 64bit  
U38N 64bit  
U45U 64bit  
U47A 64bit  
U47VC 64bit  
UX21A 64bit  
UX31A 64bit  
UX32A 64bit  
UX32VD 64bit  
UX42VS 64bit  
UX51VZ 64bit  
UX51VZH 64bit  
UX52VS 64bit  
X200CA 64bit  
X200CA Touch 64bit  
X202E 64bit  
X301A 64bit  
X45A 64bit  
X401U 64bit  
X402CA 64bit  
X45C 64bit  
X401A 64bit  
X450CA 64bit  
X450CC 64bit  
X451CA 64bit  
X501A 64bit  
X501U 64bit  
X502CA 64bit  
X55A 64bit  
X55A 64bit  
X55U 64bit  
X550CA Touch 64bit  
X550VB 64bit  
X55A 64bit  
X55C 64bit  
X55VD 64bit  
X75VB 64bit  
X550CA 64bit  
X550VB 64bit  
X550VC

 

 

Oh man didnt know that D: ... I will continue testing, and if this continues bad, i will rollback to W7 again, thanks

Statistics
86368 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.