Topic Title: alienware 17 r9 m290x
Topic Summary: drivers perfomace and such
Created On: 03/13/2014 11:37 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/13/2014 11:37 PM
User is offline View Users Profile Print this message

Author Icon
krazor8x
Peon

Posts: 1
Joined: 03/13/2014

isnt a bit odd to ayone else that amd really list no info or drivers for the r9 m290x on there site.. if i install catalyst 14.2 it says i have the 8970m, if i install dells it says i have the r9 m290x(which is whats in the laptop). any idea as to wth is going on, the 14.2 nets me a 10 fps increase over the dell driver

 05/30/2014 08:03 AM
User is offline View Users Profile Print this message

Author Icon
RavenX3
Peon

Posts: 2
Joined: 05/30/2014

Same problem here, even got the drivers from the company i ordered my laptop from.

 12/01/2014 08:34 PM
User is offline View Users Profile Print this message

Author Icon
Cervesia
Peon

Posts: 1
Joined: 12/01/2014

Same Problem Here

I just bought an Alienware 17 with a AMD Radeon™ R9 M290X with 4GB GDDR5.

As the geek that I am, I look to see the version of the driver, I go to Device Manager and look up the Display Drivers, and see AMD Radeon™ R9 M290X and see it was a Ver 13.x....   And then I went to the www.amd.com website, and see that the R9 M200 drivers is at a version 14.9.  So I said to myself, "That needs an upgrade!".

Download, Install, reboot... all seemed quite Normal.

I immediately go to Device Manager again to check the version

AMD Radeon™ HD8970M  but the Driver version is 14.301.1001.0

 

I want AMD to inform me that this is just an incorrent display information.  And I have not lost any performance from this new driver install.

 

BTW, Device Manager and AND Catalyst Control Center - Both - report the Graphics Chipset to be "AMD Radeon™ HD8970M" when it should be "AMD Radeon™ R9 M290X".

 

@AMD - what should I do?  Uninstall or will provide me a fix?



-------------------------

Old Guy

 12/01/2014 09:40 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7852
Joined: 11/13/2009

The R9 M290x is a rebranded HD 8970M. Your drivers are correct. Your laptop manufacturer should have been able to answer that for you.

Google is your friend

http://wccftech.com/amd-r9-m290x-mobility-flagship-spotted-appears-rebranded-8970m/

" Product cycles in the OEM circles, particularly when it comes to add in parts for PCs, rarely follow those in the retail market simply because expectations are quite different.  In an effort to give their new prebuilt products a fresh face, large system builders routinely require rebranding of existing solutions.  "



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 


***** cetera fallunt, ludere mortuus ******



Edited: 12/01/2014 at 09:54 PM by stumped
Statistics
88967 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.