Topic Title: ATI Mobility Radeon HD 5730 driver update fails
Topic Summary: Can't update ATI Mobility Radeon HD 5730's driver
Created On: 07/06/2014 06:43 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/06/2014 06:43 PM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

So, I needed to update my Graphics Card Driver. I went to the AMD website, selected Mobility Radeon HD 5730 drivers and downloaded catalyst. During the installation, my laptop's screen went black, which is normal. After 4 hours, the screen was still black and the HDD activity indicator stopped flashing, my laptop freezed. I shuted it down and when I turned it back on, I noticed that after Windows logo appeared, the screen had no luminosity. I had to point a lamp at the laptop to see what was going on on my screen. I checked the energy options and everything was alright, the brightness was maximized. I managed to rollback my driver to the previous one and since then I'm not able to update my graphics card driver. Any help would be appreciated

My specs: ASUS N61JQ Laptop Intel core i7 720-QM 1.60Ghz  4GB Ram  ATI Mobility Radeon HD 5730 1GB 

 07/06/2014 06:48 PM
User is offline View Users Profile Print this message

Author Icon
Practikill
Grinding Levels

Posts: 104
Joined: 08/07/2009

Do you have switchable graphics?

The generic drivers from AMD do not work for laptops with it.

You will need to obtain the drivers that ASUS provide if you do have such a setup.

Otherwise, there are stickies on the forum that explain how to do a clean install of the drivers.

 



-------------------------
 07/06/2014 06:50 PM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

No, I don't have switchable graphics. I went to ASUS website and downloaded the latest driver, but it still isn't recent enough to play certain games such as BF3.

 07/06/2014 07:05 PM
User is offline View Users Profile Print this message

Author Icon
Practikill
Grinding Levels

Posts: 104
Joined: 08/07/2009

OK....try the sticky at the top of this category about a clean install.

And report back.

http://forums.amd.com/game/messageview.cfm?catid=492&threadid=170084&enterthread=y



-------------------------
 07/06/2014 07:06 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7218
Joined: 11/13/2009

 Asus black screen

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 07/12/2014 03:08 PM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

I've tried EVERYTHING. I formated my laptop and clean-installed the drivers but I still have the same issue...

 07/12/2014 04:09 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7218
Joined: 11/13/2009

Originally posted by: djkiko22 I've tried EVERYTHING. I formated my laptop and clean-installed the drivers but I still have the same issue...

 

Did you bother to read the link I posted? You are not going to fix the problem. Report it like all the rest of us and use whatever previous drivers work for you.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 07/12/2014 10:22 PM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

Originally posted by: stumped
Originally posted by: djkiko22 I've tried EVERYTHING. I formated my laptop and clean-installed the drivers but I still have the same issue... and I've already reported it to AMD by e-mail...

 

 

 

 

Did you bother to read the link I posted? You are not going to fix the problem. Report it like all the rest of us and use whatever previous drivers work for you.

 

Yes I've tried your link. Aparently my laptop doesn't have that file in the registy so, there's not much I can do there. Also, I'm running version 8.692.1.0 and I tried updating to a more recent version (can't really remembered which one with was, sorry, but it was 9. something :/ )

 07/12/2014 10:36 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7218
Joined: 11/13/2009

Driver 13.4 seems to work well. Use the install guide found in the FAQ section.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 07/12/2014 11:06 PM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

Originally posted by: stumped Driver 13.4 seems to work well. Use the install guide found in the FAQ section.

 

Do you mind checking if this is the driver you're talking about?http://support.amd.com/en-us/download/desktop/previous/detail?os=Windows+7+-+64&rev=13.4#amd-catalyst-packages



Edited: 07/12/2014 at 11:13 PM by djkiko22
 07/12/2014 11:36 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7218
Joined: 11/13/2009

Yes thats the one. Use the install guide.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 07/13/2014 03:08 PM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

Originally posted by: stumped Yes thats the one. Use the install guide.

 

same problem as the other version. I launched the installer and it suposedly finished installing, but it didn't even ask me to restart my computer... aparently it didn't install

 07/13/2014 03:34 PM
User is offline View Users Profile Print this message

Author Icon
Practikill
Grinding Levels

Posts: 104
Joined: 08/07/2009

These days you don't really have to reboot after installing the drivers. It hasn't asked me to in years.

It is a good idea to go ahead and reboot anyway.



-------------------------
 07/13/2014 04:29 PM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

Originally posted by: Practikill These days you don't really have to reboot after installing the drivers. It hasn't asked me to in years.

 

It is a good idea to go ahead and reboot anyway.

 

I did reboot my laptop but the drivers weren't installed. :/

 08/02/2014 06:25 AM
User is offline View Users Profile Print this message

Author Icon
djkiko22
Peon

Posts: 8
Joined: 07/06/2014

Any other opinions on this issues? I'm kinda running out of options....

 08/02/2014 06:15 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7218
Joined: 11/13/2009

http://forums.amd.com/game/messageview.cfm?catid=448&threadid=169206&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

Statistics
84853 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.